求金额问题
Description
超市里卖电池,每个电池8角钱,若数量不少于10个,则打7.5折。输入购买的电池数量,求需支付多少钱?
Input
输入一个整数,代表购买的电池数量
Output
输出需支付的金额
Sample Input
12
Sample Output
7.2
HINT
如果结果为整数,则输出整数。如果结果不为整数,保留一位小数
python解法
# 输入电池数量
n = int(input("请输入购买的电池数量:"))
# 计算总价
if n <= 10:
total_price = n * 0.8
else:
total_price = n * 0.8 * 0.75
# 输出结果
print("%.1f" %total_price )
c++解法
#include<bits/stdc++.h> // 包含常用的 C++ 标准库头文件
using namespace std;
int main() {
int n;
double pricePerBattery = 0.8; // 电池单价,8角钱转换为0.8元
double discount = 0.75; // 7.5折的折扣率
double total_price;
cin >> n;
if (n <= 10) {
total_price = n * pricePerBattery;
} else {
total_price = n * pricePerBattery * discount;
}
cout << fixed << setprecision(1);
cout<<total_price<<endl;
return 0; // 返回 0 表示程序正常结束
}
如果您有更优的解法,欢迎在评论区一起交流噢~
阅读剩余
作者:小鱼
链接:https://www.52stu.com/?p=131
文章版权归作者所有,未经允许请勿转载。
链接:https://www.52stu.com/?p=131
文章版权归作者所有,未经允许请勿转载。
THE END