判断奇数偶数
Description
读入一个整数a,如果a为偶数在屏幕上输出yes,否则输出no。
Input
读入一个整数a
Output
如果a为偶数在屏幕上输出yes,否则输出no。
Sample Input
2
Sample Output
yes
HINT
除以2的余数判断法。如果一个整数除以2的余数为0,那么它就是偶数;如果余数为1,那么它就是奇数。
python解法
a = int(input("请输入一个整数:"))
if a % 2 == 0:
print("yes")
else:
print("no")
c++解法
#include<bits/stdc++.h> // 包含常用的 C++ 标准库头文件
using namespace std;
int main() {
int a;
cin >> a;
if (a % 2 == 0) {
// 偶数
cout<<"yes";
} else {
// 奇数
cout<<"no";
}
return 0; // 返回 0 表示程序正常结束
}
如果您有更优的解法,欢迎在评论区一起交流噢~
阅读剩余
作者:小鱼
链接:https://www.52stu.com/?p=130
文章版权归作者所有,未经允许请勿转载。
链接:https://www.52stu.com/?p=130
文章版权归作者所有,未经允许请勿转载。
THE END